Welcome, Guest
You have to register before you can post on our site.

Username
  

Password
  





Search Forums

(Advanced Search)

Forum Statistics
» Members: 176
» Latest member: WilliamBoomi
» Forum threads: 37
» Forum posts: 90

Full Statistics

Online Users
There are currently 13 online users.
» 0 Member(s) | 13 Guest(s)

Latest Threads
Video card/ Graphics card...
Forum: RoboDK bugs
Last Post: josuevivash
11-07-2017, 01:19 PM
» Replies: 2
» Views: 598
Export Simulation with Pa...
Forum: General questions about RoboDK
Last Post: RoboDK
10-28-2017, 09:02 PM
» Replies: 1
» Views: 3,033
Smoothing or Continuous M...
Forum: General questions about RoboDK
Last Post: RoboDK
10-28-2017, 08:47 PM
» Replies: 1
» Views: 2,305
Kawasaki Post Processor n...
Forum: RoboDK bugs
Last Post: RoboDK
10-28-2017, 08:34 PM
» Replies: 2
» Views: 3,376
KUKA connection
Forum: General questions about RoboDK
Last Post: RoboDK
05-15-2017, 08:26 PM
» Replies: 5
» Views: 12,205
Access points from an ite...
Forum: General questions about RoboDK
Last Post: RoboDK
04-09-2017, 06:12 AM
» Replies: 1
» Views: 4,923
Change the joint limits
Forum: General questions about RoboDK
Last Post: RoboDK
12-18-2016, 11:08 AM
» Replies: 1
» Views: 3,940
Change tool number?
Forum: General questions about RoboDK
Last Post: RoboDK
11-26-2016, 05:04 PM
» Replies: 1
» Views: 4,169
MoveC abb
Forum: General questions about RoboDK
Last Post: RoboDK
11-11-2016, 07:50 AM
» Replies: 1
» Views: 4,844
New robot creation
Forum: General questions about RoboDK
Last Post: RoboDK
11-11-2016, 07:33 AM
» Replies: 1
» Views: 6,497

 
Lightbulb Video card/ Graphics card Nvidia Quadro low performance
Posted by: josuevivash - 11-02-2017, 12:03 PM - Forum: RoboDK bugs - Replies (2)

Hello There,

I wanted to share a little struggle that some might have

I run RoboDK on a laptop with Intel and Nvidia Quadro graphics cards. Turns out that RoboDK underperforms if I run it with the Nvidia Quadro (with the latest Nvidia drivers). 

I found something very curious. If you run the Direct 3D or OpenGL modes of RoboDK it underperforms anyways; sometimes crashes. (RoboDK-D3D and RoboDK-GL2 in the bin folder)


It will be amazing to understand the  3D settings of the app to take advantage of the resources. Can any of you indicate which rendering engine the app runs? we could get more stability and performance from the system by knowing the 3D settings that the app performs the best.

I downgraded the Nvidia drivers to WDDM 2.2 windows certified drivers for the Quadro and intel HD, and the rendering performance increased. But still, I have to run roboDK with the Intel HD graphics card using the default "RoboDK.exe" application in the bin folder.

I had to stick to old drivers to get stability, but other software might suffer by using old drivers, something that with time will be hard to keep. 

Hopes this helps others. 

Best,
Josue


Lenovo P40Yoga. Windows 10 64 Bit, 16 GB RAM. intel HD graphics 520/ Nvidia Quadro M500M

Print this item

  Smoothing or Continuous Move
Posted by: MLG - 06-02-2017, 07:53 AM - Forum: General questions about RoboDK - Replies (1)

Hello All.  I created a simple pick-and-place simulation and would like to use a continuous move through the waypoint between Pick and Place locations.

Can someone tell me how to do a smooth, continuous move through the intermediate point?  I thought the Smooth (Rounding) instruction would give me that, but it doesn't appear to have any effect.

-Leland

[Image: RoboDK_2017-06-02_03-25-40.png]

Print this item

  Export Simulation with Paths and Origins
Posted by: MLG - 06-02-2017, 07:30 AM - Forum: General questions about RoboDK - Replies (1)

Does anyone know how to make a demo that shows the path, tool flange frame, target origins, etc.  I need to  include the tool and target orientations in my video.

-Leland

[Image: RoboDK_2017-06-02_03-25-40.png]

Print this item

  Access points from an item
Posted by: Tobias7 - 01-11-2017, 11:01 AM - Forum: General questions about RoboDK - Replies (1)

Hey!

I am not that familiar with Python yet.
Nevertheless, I added an item with points to an object by

points = obj.AddPoints(PointsDataList,False,...)

which is also shown in the RoboDK window/tree.

The Question is: in which way are the generated points accessible from Python? (e.g. extract the points if the rdk file is reloded)


Thanks.

Print this item

  Change the joint limits
Posted by: Hamid - 12-14-2016, 06:46 PM - Forum: General questions about RoboDK - Replies (1)

Hi,

I know that with JointLimits(self) you can read the joint limits. But is it possible to change the joint limits? Because in the real robot  it is always less than the nominal values.

Hamid

Print this item

  Change tool number?
Posted by: galex - 11-23-2016, 05:48 PM - Forum: General questions about RoboDK - Replies (1)

Where change the UTOOL number for Fanuc?

Print this item

  pick/place using robot + linear rail
Posted by: fennex - 11-04-2016, 04:15 PM - Forum: General questions about RoboDK - Replies (1)

Hello,

I'd like to make a program that uses a 6X robot mounted on a linear rail:

rail at 'home'
robot goes to 'target1'   (defined in a frame 'world' -not relative to robot) (picks a part here)
robot moves along rail to 'rail end'  (max travel)
robot goes to 'target2'    (defined in a frame 'world' -not relative to robot)  (places the part here)

Seems easy enough but I can't seem to figure it out.

Rail seems to work fine, I can move it in a program.

In attached RDK file, prog3 is what I want.



Attached Files
.rdk   test.rdk (Size: 1.06 MB / Downloads: 216)
Print this item

  trouble when installing RoboDK on Ubuntu 16.04 (xcb plugin missing)
Posted by: rüdiger - 10-11-2016, 12:11 PM - Forum: General questions about RoboDK - Replies (1)

Dear RoboDK-Staff and all the smart people out there,
I use Ubuntu 16.04, running on a 64bit-machine, so I downloaded RoboDK directly from the webpage (http://www.robodk.com/download)
As far as I know, python3 is installed and seems to work (although I never used it before). As the "run.sh"-file in the package tells me, I just need to run sudo ./RoboDK in the /bin directory to get it installed; when I try this, it responses: 

This application failed to start because it could not find or load the Qt platform plugin "xcb".
Reinstalling the application may fix this problem.

Some other people, trying to install another application, seemed to had the same problem. They usually solved the problem by installing a missing library-file, but in my case alle those, mentioned in the number of forums, I checked, are installed.

Maybe it's a known problem and there's just a simple hint or I missed an important step... I am on it for three hours now, so I am pleased for any help.


regards
-rüdiger

Print this item

  Custom Conveyor
Posted by: mbrown - 09-28-2016, 07:27 PM - Forum: General questions about RoboDK - Replies (1)

I want to do a simulation where I have a custom conveyor that moves like the example video does. How is this possible? I have the conveyor python program but I  don't know how to link the program and the conveyor and get it to run. Any help is appreciated.

Print this item

  MoveC abb
Posted by: vissermatthijs@hotmail.nl - 09-26-2016, 11:14 AM - Forum: General questions about RoboDK - Replies (1)

Hello,

I am working on project to transform a old abb irb6400 robot with s4 controller to a CNC machine. The problem in the preprocessor is that the move circular is not included. I want to include my self but er must reason why it is not implemented?

Print this item